
Problem-solving lessons

Chickens

Chickens (part 1)

Lucy shows us what she’s already built

We outline the problem: is a chicken a good return on investment?

In Lucy’s sheet, nothing is linked; everything is entered manually; 
maths is done by hand

Our first concept is the idea of ‘defining the problem’

We separate Lucy’s notes from her actual data

We introduce our first keyboard shortcut: pressing tab finishes 
what you’re doing and moves you to the cell to your right

Chickens (part 2)

Neat trick: double-clicking column headers 
makes them just as wide as they need to be

Our first introduction to types

We look at how Excel stores currency and dates

This solves Lucy’s weird issue with a number turning in to a date

We copy Lucy’s data over and see that it keeps the formatting

⌘ ` (backtick – the key above tab on a US keyboard) is a 
handy keyboard shortcut which switches between all 
of the windows in your current application

Excel shows ##### when the column is too narrow

We take a quick look at the AutoSum button, 
which Lucy already knows

Egg log (part 1)

We review the ‘egg log’ that Lucy has created

Lucy tells us what she’s learned about 
functions, cell references, and ranges

Lucy’s been thinking about the types of data in her sheet

Lucy’s defined her problem

She shows us the three versions she’s come up with

We do some basic troubleshooting because 
her formula isn’t adding up right

Egg log (part 2)

We pick our favourite from Lucy’s three sheets

Lucy has used the fill handle which she also knows a little about

We show how the fill handle can help you fill dates in a column, 
and numbers that repeat

Johnny briefly shows what else the fill handle can do

We add a new row to the egg log…

…and see what’s happened to Lucy’s formula as a result

This causes us to re-arrange the sheet a little

This shows us how Excel often just ‘looks after it’ 
when you move things around

We change Lucy’s formula from calculating a range of cells 
so that it looks at the entire column

We show how you can copy/paste formulas and 
have the references ‘follow you’ across the sheet

We look at the little Paste Options helper that appears 
when you paste in to a cell

We drag some cells using the little hand that appears when 
you’re on a cell border (which Johnny never actually uses)

We learned to think in entire rows or columns of data

Chickens (part 3)

Lucy takes everything she’s learned so far and 
revisits her original chickens sheet

She’s avoided hard-coding values in her formulas

She’s used PRODUCT then SUM

And cell references to other sheets

Chickens (part 4)

We find out when the chickens become debt-free

Lucy has used TODAY to figure out how many 
eggs per day since the girls arrived

We talk about errors and what to do when you see one

Lucy tells us how she’s been using the fill handle

Tracking our weight

Tracking our weight (part 1)

Remember, this is not medical advice 

😷

We take a brief look at Lucy’s original sheets

We define our two ‘problems’

First: making a thing that we print out and stick 
inside the kitchen cupboard

Second: recording the weights that we write on 
that sheet and doing something with the data

Tracking our weight (homework)

Lucy gets homework, and solves it … almost! 

😜

This demonstrates how Excel evaluates each 
argument, which is kinda interesting

Cell Styles lets you quickly colour cells – as an 
‘Input’ in this case

Business Class 1: email 
address generator

Email generator 
(part 1)

We review the project requirements (which you’ll 
never get, unless you write them yourself)

First up: sniff around. See what the data you 
got given looks like; assume that it’s rubbish

Always Be Tabling!

LOWER takes a single argument and returns a 
lowercase string; UPPER is its opposite

We see that copy/pasting cells that contain a table reference 
doesn’t work the same as it does with a cell reference

Email generator 
(part 2)

We can use the filter to quickly find things – like 
a name with a dash in it

SUBSTITUTE is like find/replace for Excel

You might be tempted to be lazy sometimes and 
not create a column if it feels like you don’t need 
one: but think of future users of your sheet

⚠

 Note that the keyboard shortcut for ‘find the next 
blank cell’ – ⌘/ctrl arrows – might not work in a cell 
that has a function: the function has returned a value

Hiding columns (or rows) is a great way to get stuff 
you’re no longer using out of the way

We discover a couple of rows with errors – keep your eyes 
out, don’t just ignore something that doesn’t look right

Email generator 
(part 3)

We see an IF again: in this case we check IF the 
surname is blank: [@Surname]=""

If it’s blank, there’s no surname, so we return FALSE; 
otherwise there is, so we return TRUE

If you want to check if something is not equal to, 
use: [@Surname]<>""

We meet Boolean logic: why TRUE AND TRUE 
is TRUE, FALSE OR FALSE is FALSE, and so on

Email generator 
(part 4)

Almost there! We use another IF with a CONCAT 
to join the names together

We see how nice the table notation makes 
formulas: you can almost read them like a sentence

You can use your inserting-hard-return skills to 
make a formula more readable by breaking it up

We add the @example.com to our existing CONCATs

One more formula: COUNTIF counts how many 
times this range contains this value

We count how many times all of the names 
contain this name

With the help of the filter, this is a really easy way of 
finding duplicates

Finally, we use another IF to return an empty string IF 
the COUNTIF returned a number >1

Mostly harmless

Mostly harmless 
(part 1)

⚪⚪⚪

If you see three dots (an ‘ellipsis’ – …) after a menu option, this 
means that something else will appear when you select the thing

So you can generally click these items just to see what happens 
next without worrying that something will immediately change

On a Mac, holding Option often changes the behaviour of a menu 
item. For some system options, it removes the ellipsis, meaning 
clicking the menu bar item will take the selected action immediately

🕵

How does Johnny know so much? He just clicks everything to see what it does!

Be curious

⌨

F2 is the standard ‘edit this cell’ shortcut in Excel

F2 on a laptop usually does something else, 
like change your brightness

So you might need to press fn F2

On a Mac, ctrl U also edits a cell

⏩

To move between worksheets with the 
keyboard, use ⌘/ctrl page up/down

On a Mac laptop fn arrow up/down is the 
same as page up/down, so ⌘ fn arrow up/
down switches between worksheets

🏡

 

🔚

Similarly, ⌘/ctrl home/end take you to the very beginning (top-left) 
and end (bottom-right) of your worksheet, ignoring islands

On a Mac laptop fn arrow left/right is the same as home/
end, so ⌘ fn arrow left/right is what you want here

Just hack around on your own keyboard: shortcuts are worth learning!🎨

Page Layout > Themes, Colours, Fonts is just a bit of fun

Say goodbye to that terrible default colour palette!

🎨

The trick to removing the gridlines in Excel is to 
fill the background as white

🎨

A trick to flatten a sheet: select everything and 
hit Wrap Text a couple of times

This is often handy when you inherit someone 
else’s nonsense at work

🎨

In Page Break Preview mode you can move the 
blue lines just by dragging them

Mostly harmless
(part 2)

🔒

If you can’t open a new file, it might be because 
you’re in edit mode in another sheet

🧵

Just like you can use the + operator in place of SUM, 
you can use the & operator in place of CONCAT

💬

If you start a cell with a single apostrophe ', 
the cell will be treated as text

No functions will be evaulated; true isn’t TRUE; 
and so on

You can do something similar by formatting the cell as Text, 
but Johnny prefers the apostrophe method as it’s more 
explicit and robust

⬅➡

You can re-size multiple columns at the same time by 
selecting multiple columns and dragging one of their headers

(Or rows, of course)

ℹ

There’s a handy status bar at the bottom of the window 
which does quick maths for you — SUM is there by default, 
and you can right-click to select others

🫣

To un-hide hidden columns/rows, select over the hidden area 
then right-click and Unhide

🙅

Don’t use the ‘this row’ [@[Column name]] syntax if you’re 
not actually in the table containing the row

Otherwise things move around and now ‘this row’ is 
a different row … weird

😎

In our data filters, you can filter by condition: 
greater/less than, text contains, all sorts

🤹

You can use Data > Sort to do just that

You can build complex Sort queries, and Reapply them, 
which is really handy…

…but be careful! Doing a Data > Clear will clear your sort 
as well as your filter conditions 

☹🚨

Mostly harmless
(part 3)

We’re going to talk about things that live in the ‘window chrome’ 
around the main Excel grid

Turn off that annoying ‘Gallery View’ thing that Excel shows you when you open it!

You can hide the ribbon if you need a bit more room: 
just click the name of the ribbon item that you’re already on

And you can expand the Formula Bar just by dragging the divider at the bottom

And quickly expand/contract it using the triangle at the very right 

🔽

The 

💡

 Tell me box is real handy — just type a feature and it saves 
you having to find it in the ribbon

On a Mac, the system menu bar Help option lets you 
search for any menu item

(And by the way you can assign your own keyboard shortcut to any Mac 
menu item, in any application. Look that up online if you’re interested.)

You can customise the buttons on the very very top row of the Excel window, 
which is the Quick Access Toolbar

If you want to lock some cells in place, you have a few options. 
First (and this is what most people usually use): 

🥶

 Freeze Panes

It’ll freeze above and/or to the left of the cell/row/column that you have selected

Alternatively, you can Split the window — slightly different, 
and this allows you to move the split around

You can open as many New Windows as you like — most useful if you want 
to view two worksheets from the same workbook side-by-side

Johhny has a little rant about window management, 
and Lucy tells us stories about an old colleague 

👴

You can annotate cells a few ways: 

📒

 Notes is the old 
way, and it’s a bit rubbish, so try not to use it

💬

 Comments is the new way, and they’re much nicer

Excel moved the R1C1 option since we recorded our episode! 
It’s now in Settings > Calculation

The Excel blog is pretty good, by the way. Click here to go there!

Personal accounting

Personal accounting 
(part 1)

As an introduction to this learning pack, Lucy shows us some of her pre-Learn-with-Lucy 
sheets, and tells us how she used to manage her finances as a freelancer

Personal accounting 
(part 2)

Now that we’ve learned all of the topics that we covered in 
this pack, we rebuild Lucy’s sheets using what we know

We start with a table which lists our Clients

You should be thinking about how your data is separated — Clients are 
separate from Projects are separate from Timesheets, and Invoices

The first thing we do is validate the list of Clients in or Projects table 
against the list of Clients in the previous sheet

It might be a good idea to use Conditional Formatting to check to see 
if we have any duplicates in our Clients table

Before we use our Clients table as a validation range, we need to do that weird 
thing where you need to define a name that you can use in Data Validation

If you are setting Data Validation against a table, it’d be nice to use your validation 
Error Alert to tell people where the list is, so they know what to update

We have a quick look at the formatting differences between Currency 
and Accounting. Johnny prefers Accounting

And we look at the options you have for making a date look exactly 
like you want — we put the short day of the week at the start

Personal accounting 
(part 3)

We set up validation on our Timesheets table against the Projects table

And show how data validation errors are shown, and have another look 
at Circle Invalid Data

At Formulas > Error-checking there’s also a dialog box that will show you 
all of the errors on your sheet

In our Timesheets table, we set up a VLOOKUP to retrieve the Client 
according to the Project

We make it a bit neater by wrapping this in an IFERROR — 
hiding the #N/A and making it blank instead

By pasting in data we see the Inconsistent Calculated Column error

Adding a new row to the table shows that our custom date format doesn’t 
apply — which is annoying. We use the Format Painter to fix it

Invoice numbers are another really obvious place to put some Conditional 
Formatting to highlight the duplicates

We use some simple maths to calculate our invoice due date

Personal accounting 
(part 4)

SUMIF is introduced, to SUM our hours IF the invoice matches

We grab your rate from the Projects table with another VLOOKUP

In calculating our GST (sales tax), we name the cell rather than 
using an absolute cell reference

Now that we’ve got some timesheets, we can use SUMIF again 
to calculate the hours worked against each project

Personal accounting 
(part 5)

Now that we’ve calculated how many hours remaining you have on each project, 
we can use Conditional Formatting to highlight our high/low values

A Pivot Table is a really nice way to show our invoices — we can group 
by client and project to see how much each has earned us

We put on a new field which is % of Grand Total…

…and put Conditional Formatting on that!

Our bank transactions are imported with a Power Query

We use FIND and MID to extract the ‘INV000x’ text from our transaction description

Personal accounting 
(part 6)

Now we use this extracted invoice number with SUMIF to figure out 
when we’ve been paid

One of our invoices hasn’t been paid (typical!), so we use Find to search 
our entire sheet for the invoice number just to be sure

Finally, we put together some ad-hoc summary calculations

Business Class 2: stocktake

Stocktake 
(part 1)

We intro this second Business Class, with a note that we’ve squeezed in 
to an hour something that took Johnny a couple of months – so it’s as 
realistic as it can be, but bear that in mind!

The problem: Derek used to look after our company’s inventory data, 
and it’s a right mess. We review the sheet that we’ve inherited

This is what you should do if you inherit a sheet at work: 
spend some time to understand what’s in it, then tidy it up

In this case we do make a copy of Derek’s data with Move or Copy, 
and then we hide it

Zoom out and check your whole data set: predictably enough, 
we have a blank row

Derek’s formats are a mess, so we just select the whole sheet and Clear Formats

And then of course we make it a table

The model description that we inherited is hard-coded; but we have a 
model code lookup table, so let’s make this a VLOOKUP

Our serial numbers are messy, so we use UPPER, TRIM, and SUBSTITUTE 
to tidy them up

These text functions have a nice side-effect: they convert numbers to strings, 
which is what we want here

Stocktake 
(part 2)

We bring the model description from the models table with 
a VLOOKUP, so we can compare to Derek’s original values

Comparing values can be fraught with danger: the '=' operator doesn’t match 
numbers stored as strings with the same number stored as a number

There are ways to ‘force a type’ (computer programmer term): 
e.g. TRIM always returns a string

The TYPE function reveals the type of a cell’s value

A better way of comparing cells is to use the EXACT function, 
which doesn’t have these issues

This reveals some of Derek’s typos, but stranger is where we have a 
#N/A match against the model code

This leads us to do a reverse-lookup of the model description, 
for which we use XLOOKUP

This is because we need to look ‘backwards’ in the models table, 
which doesn’t work with VLOOKUP

And there’s no more ‘comma-FALSE’ with XLOOKUP! 

😀

This reveals a set of common typos: 2 has become Z; 
5 has become S; 1 has become I; 0 has become O

We’d like to paste values the correct values over our existing values, 
but we’re filtered: so this won’t work

The trick is to sort your data to group the items together: 
now you can copy/paste

Stocktake 
(part 3)

Now that we’ve done an initial clean-up, we need to extract the 
data for each of our 3 remote sites

We use the FILTER function to extract all barcodes that belong to 
a particular city — it returns an array, which is funky

The problem with FILTER — and all other functions that return an array — 
is that you can’t make the resulting data a table

(Johnny didn’t know this function before this lesson, he just 
found it online and read the instructions)

Then we use VLOOKUP to grab the serial number and 
description based on the barcode

We use a simple list — just entering a comma-separated list of values — 
to enforce some data validation on our last column

The customised sheet for Canberra is then copied out to its own workbook 
using Move or Copy > Create a copy

To erase the formulas from this new sheet, we 
copy the entire sheet and Paste Values

Now to export for Melbourne and Hobart, we just update the name of the city 
and FILTER takes care of the rest for us – almost!

Because when you do this sort of thing you should always jump to the bottom 
of your data and check that everything has filled across all of the columns

☕

 Take a coffee break 

☕

Okay, the stocktake sheets are back from our regional sites: time to 
bring them back in to our master data

We do this by using Move or Copy again – this is a very common way 
of getting data between different sheets

Now we need to smush these tables back together: so we just copy/paste the 
data out, and add a new column to indicate which site the data came from

Conditional Formatting helps us find the ‘dups’ in the data (or duplicates if you 
insist on saying the whole word 

😒

)

And this reveals items that were found at one place and not found elsewhere: 
they’ve moved. We just delete the rows that represent the old data

Stocktake 
(part 4)

Now we want to check our original serial number against the version sent back 
from the site: so we add a new column and XLOOKUP the new barcode

And then see if they match with EXACT

The errors look like typos: so we just throw away Derek’s old data and use 
the new data that we know is good

But we don’t want to keep that as an XLOOKUP, so we copy/paste values

Similarly we bring in the item’s new location (with VLOOKUP this time, 
just for practice) and compare against our original value (EXACT again)

Finally, we want to record an updated last seen date 
for each item based on the stocktake

We create a new table to track each site’s stocktake date, 
and then use XLOOKUP to get the date based on the city

A nicer version is constructed using CONCAT, with help from 
the TEXT function to format the date properly

TEXT is another one of the tricks Johnny uses to get a long number 
looking just like a number and not in scientific notation

👏

 Pat on the back, everybody! That’s it, you made it

Concepts

Find & ReplaceFind & Replace (part 1)

There’s more to Find than the ‘Find lite’ box up at the top-right of the window

ctrl F (Mac/Windows) will bring up the full Find & Replace dialog

The Options might be hidden for you — click the button to reveal them

You can find Within: Sheet (the sheet you’re looking at) or 
Workbook (the entire file)

You can Search: By Rows or By Columns, which just alters the ‘direction’ that 
Excel searches, i.e. which result it finds first — Johnny rarely changes this one

And the one that can cause you problems is Look in: Formulas, 
Values, Notes, Comments

So if you’re Looking in: Formulas, you might not see what you’re looking for. 
The most common ‘gotcha’ is that you need to change this to Values

(By the way, in Pivot Tables Lucy wondered if she could search someone else’s 
sheet for the GETPIVOTDATA function. This is how you could do that.)

You can turn on Match case, which will only return results that ExaCTly MaTCh 
according to the case of the letters

And Find entire cells only which needs to match the entire cell to return a result

All of this works with Replace, just hit the Replace tab to activate it

If you have more than one cell selected, Find will only look in the selected cells

This can be a) very handy if you want to narrow down your search and 
b) a cause of confusion if you don’t realise what you’ve done

You can’t search for the name of a worksheet, but if you right-click the arrows at the 
very bottom-left of the window you’ll get a pop-up window with all of your sheets listed

Validating dataValidating data (part 1)

Anoooother warning from Johnny to not get carried away with this 
feature: don’t create problems for other people at work

You can limit what can be entered in a cell: click Data > Data Validation

And you can put custom messages on a box to tell people 
what sort of values you need to enter

You can limit based on the actual number in the cell, based on how many characters 
are in the cell, or you can specify that the cell has to contain a date, or time

Or you can limit the contents of a cell to any list of things that you specify

You can just specify a range, but this won’t expand as you add items to it

And unfortunately you can’t use table notation to specify a table column

The hacky workaround — which we recommend — is to define a name 
which points to a table range, then use this name as your list

But follow the Excel blog! Because Johnny expects one day to 
be able to use table notation here

Keyboard shortcut! Option/alt down arrow will show you the 
list of possibilities, then you can use the arrows to select

Using validation can help with data hygiene

If you want to define a quick ‘n dirty list, you can just type a 
comma-separated list of values directly in to the box

Naming cellsNaming cells (part 1)

A nice little trick: you can give any cell (or range) a name

If you find yourself using an absolute cell reference ($A$1) you should think, can I name this cell?

You can just type a name up in the Name Box (to the left of the Formula Bar)

You can use the Name Box to jump to anything that has a name — tables, ranges, whatever

You manage your names in Formulas > Name Manager

You can also create a name using Formulas > Define Name, and this 
allows you to limit the scope of your name to just the worksheet 
you’re on (but don’t bother unless you have a really good reason)

Conditional Formatting

Conditional Formatting (part 1)

You can use conditional formatting to automatically highlight cells 
that are greater than, less than, between, or equal to a value

There’s a few ways to do it: the first way we look at we apply it to 
a single cell then use the Fill Handle to Fill Formatting Only

You could also copy/paste formatting, or you could use the 
Format Painter

Or select all of your data first and then apply your conditional formatting

Or use the Applies to range in Manage Rules

They all end up with the same result

Conditional formatting overrides any standard formatting, if they conflict

We have a look at the Manage Rules dialog where 
all of your rules are shown

Unfortunately you can’t use table notation here: 
if you try, it just reverts to $A$1 style referencing

You can also highlight a cell that contains a text string

There’s all sorts of other stuff: data bars, colour scales, icon sets 
— have a play and see what you can do, it’s all really visual

If the rule is created with an automatic mininum/maximum you can 
override it and specify values yourself; Johnny does this with things like 
percentage complete values at work, where 0% is red and 100% is green

Conditional Formatting (part 2)

You can use a formula to conditionally format cells: 
if it returns TRUE, the formatting will apply

It’s a bit of a faff: click Conditional Formatting > New Rule… > Style: Classic > 
Use a formula to determine which cells to format 

🥵

When you do this, watch your relative vs. absolute cell references: 
if you make them absolute, they won’t fill down your sheet

Careful when you copy/paste cells that have conditional formatting 
applied: the rule will also be copied, and you can end up in a right mess

Probably the nicest way to extend a formatting rule — should have mentioned 
this at the start! — is to use the Applies to range in the Manage Rules dialog

There’s a rule to highlight Duplicate Values which is really handy

And you can use the filtering that we’ve already looked at to filter on a colour

We look at the shortcut way to arrive at a Boolean: 
rather than using IF, just evaluate the statement directly

So =A1>25 will return TRUE if the value in A1 is greater than 25

And =A1="Personal" will return TRUE if A1’s value is ‘Personal’

And both will return FALSE otherwise

Conditional formatting rules are applied in an order, and you can move them 
above or below each other with the arrows in Manage Rules

You can use =TRUE to create a ‘default’ rule that will always apply

Pivot Tables

Pivot Tables (part 1)

We insert a pivot table using, no surprise, Insert > Pivot Table

Just like when you create a table, you get an option for where you want to put it

And just like a table, you can move it later…

…and you should give it a decent name

To build your table, you drag fields in the PivotTable Fields 
section on the right side of the screen

You can drag multiple fields in to each section if you want

The whole thing is very visual: just drag things around

If you double-click on any value in a pivot table, 
Excel will extract the values that make up that cell; it’ll 
put them in a new table on a new sheet for you

Be careful because this data isn’t linked 
to the original: it’s a point-in-time extract

We check out the Pivot Table Options

Active Field tells you which field your cursor is in … and you 
can type in it, which we don’t understand, so just don’t do that 

😛

But it’s handy to know where you are before you click Field Settings, 
which is where you can change the number formatting

This is also where you can change the way Excel is 
summarising your values: typically you want SUM or COUNT

Pivot Tables (part 2)

If you add/remove rows from your source data, 
you need to manually Refresh your pivot table

The Slicer and Timeline are cool

We have a look at the options on the Design ribbon

Our house inventory data is really interesting in a pivot table — 
we’ll make the data available, play with it!

GETPIVOTDATA is a handy function

But be careful because if the ‘shape’ of the pivot table 
changes, you might end up with a #REF! error

VLOOKUP

VLOOKUP (part 1)

We note that VLOOKUP is a historical function; the 
‘V’ stands for vertical

There’s also HLOOKUP for horizontal lookups 
(which is much less common)

XLOOKUP is the new function, you should check it out

VLOOKUP allows you to reach in to a table of values and return 
one of the columns associated with the value that you specified

The crucial limitation is that the first column of the table 
you specify must contain your lookup value

The last argument to VLOOKUP should almost always be 
FALSE: don’t forget it, because if you do the default is TRUE!

If your lookup value isn’t found, #N/A is returned

Be careful when specifying your lookup range: you probably 
want some sort of absolute reference

The third argument, a number, specifies which column to return: counting 
from 1, which is the first column containing the value you looked up

You might also want to lock the column component of your lookup value; 
this allows you to fill your formula across

Using a table as your lookup target is especially nice: just use 
its name (assuming that your lookup value is in its first column)

VLOOKUP (part 2)

We show how you can nest a formula — CONCAT in this case — as 
the first argument; so we’re VLOOKINGup the result of the CONCAT

A common pattern is to lookup the result of a previous lookup: 
we show this with users, apps, servers, and locations

If you leave the last argument blank, or specify TRUE, 
you get an approximate match

This is handy when you’re looking up things like numbers in 
a table where the exact number you’re looking for isn’t there

But be careful! If you use this with a lookup value that isn’t 
a number, you’ll probably get unpredictable results

We use this to match our transactions using a ‘lookup table’

We use FIND, MID, and TRIM

Advanced
cell referencing

Advanced cell referencing
(part 1)

We’re back in the world of A1-style cell references, vs. table style

We show the problem with relative referencing: 
when you fill down, it often goes wrong

This is because the relative range ‘follows you’ 
down the sheet as you fill

For a ‘behind the scenes’ look at the formulas 
rather than the results, hit ctrl `

By default, Excel treats all references as relative, 
which is usually what we want

Advanced cell referencing
(part 2)

R1C1 reference style is actually what Excel uses ‘under the hood’

R = row, C = column

(Notice they’re flipped from the A1 way, which indicates column then row.)

Square brackets are a relative reference

R[1]C is one row down, this column

R[-1]C is one row up, this column

RC[1] is this row, one column to the right

RC[-1] is this row, one column to the left

We bump in to the green triangle of mystery again, 
when it warns us about an inconsistent formula

In R1C1 mode, when we copy/paste or fill a formula, 
it’s the same formula!

To specify an absolute reference in R1C1 mode, 
don’t use the [square brackets]

R2C3 = row 2, column 3 (which is cell C2 
in our usual style)

R16 = row 16, all of it

C9 = column 9, all of it

An absolute reference never changes, no matter where you copy it

And finally we discover what the $ means: it’s how we indicate 
an absolute reference in A1 style

So $B$6 means column B, row 6, and that’ll never change

Advanced cell referencing
(part 3)

We look at a COUNTIF example, locking different parts 
depending on what we want to do

There’s no rule that can tell you what to lock (if anything): it all 
depends on your data and what you’re trying to achieve

We construct an example ‘calendar’ using CONCAT

And another COUNTIF

This lesson is hard to summarise in words! 

😜

Importing data

Importing data 
(part 1)

We talk about how importing data, and keeping the connection 
to the data, is fundamentally different from copy/pasting that data

A very common format is the comma-separated values file: a .csv

If you just double-click a .csv file, it’ll open in Excel

(Unless you have Apple’s Numbers program, which might 
have taken the default. You can change that if you want.)

You can open a .csv in any program, because actually it’s just text

Be careful with .csv files: a stray comma will 
put everything out of whack!

And be careful not to use Excel features and then save the .csv: 
it isn’t an Excel file, and the fancy stuff will disappear

And be careful saving as an Excel file: make sure it’s the 
new .xlsx and not the old ‘Excel 97-2004’ .xls

Importing data 
(part 2)

Data > Get Data (Power Query) to import data

This is the new way, which you should prefer: 
we show you the old way in a bit

Excel looks at your data and tries to figure out your types

Once you’ve made a connection to an external data source, 
right-clicking on your table gives you a Refresh option

Excel names the table it creates based on 
the name of the file you imported from

👵

 We feel like we’re nagging, but guess what: be careful! 
When you refresh your data, it’ll overwrite whatever you 
have in your table, including any changes you made

Also if rows are added or deleted from your source 
data, it’ll cause any hard-coded data in your Excel table to 
become misaligned

Always Be Checking! You just have to be 
diligent and check your own data

When you reopen a file with an external data connection, 
Excel will warn you and stop the connection from 
refreshing until you say it’s okay

We have a look at the options in Data > Properties

You can Refresh data when opening the file, which is useful

And Remove external data from worksheet before saving

There’s also Data > Queries & Connections

This shows your connections; if you select one, 
you can Remove it to break the connection

Importing data 
(part 3)

You can use Paste Special to import comma-separated data 
that’s on your clipboard

You can also Use Text Import Wizard… which is the ‘old way’ — 
this also works with clipboard data

Of course, importing data from your clipboard doesn’t keep 
any connection to wherever you got your data from

We look at the ‘old way’ in more detail: Get Data > 
From Text (Legacy) launches the wizard 

🧙

The properties of the connection when you make it 
the old way are different

By default, Prompt for file name on refresh is turned on 
— you probably want to turn it off

The main issue with the old way: you can’t use a table while 
also retaining the connection to your data 

☹

We close by reminding you that you should Always Be Checking: 
don’t just right-click, hit Refresh, and go to lunch

Errors
(Don’t panic)

Don’t panic 
(part 1)

We change the green triangle of mystery to be … pink

#VALUE!
Usually some sort of type error

You’ll see this if you pass the wrong type of 
arguments to a function

There’s an error helper but we’re not sure it’s all that helpful

#N/A

The ‘softest’ of the errors

Excel will handle #N/A gracefully: trying to do maths 
on it just gives you another #N/A

Common lookup functions (we’ll see VLOOKUP later) return 
#N/A if the thing you were looking for wasn’t found

The function NA returns the value #N/A

We compare #N/A to just leaving a cell blank or 
returning the empty string

#NAME?
A function or a reference isn’t recognised

Probably a typo! Check your work

Don’t panic 
(part 2)

#REF!

An invalid reference

Excel doesn’t know where to go

We create a namespace conflict by calling a table 
‘concat’ … which Johnny thinks is really dumb

#DIV/0!You can’t divide by zero because the answer is infinity

#NUM!

You’re trying to represent a number which is larger than 
Excel can handle … which is a ginormous number that you’ll 
never need unless you’re some sort of multiverse astronomer 

🌌

Or a number that it can’t handle, like the square 
root of -1 which is the (very cool) imaginary number

#NULL!

Something something you put a space instead of 
a comma something something 

🤷

(Johnny has never seen this error in real life)

#SPILL!

You’ll see this if you try to put data inside a range that 
Excel has reserved

Or other scenarios — this is another one that Johnny 
never runs in to in real life

#CALC!Literally no idea … move along, nothing to see

Don’t panic 
(part 3)

We introduce the concept of trapping or catching an error

We say that the computer throws an error; you can throw 
an error yourself if you want

ISERROR returns TRUE if its argument evaluates to an error

You typically use this with an IF to catch and deal with an error

ISERR does the same, but it doesn’t treat the ‘soft error’ 
#N/A as an error

IFERROR is an error handler function: if the first 
argument isn’t an error, it just returns it; if it is, it returns the 
second argument

We look at filtering errors using the data filter: 
they’re grouped together at the bottom

Charts

Charts (part 1)

Johnny confesses that he’s not very good at charts — but 
luckily it’s got a lot better since Lucy last tried it in 2001

With an abridged version of our weight data, we 
use Recommended Charts to insert a new chart

Our recommendation is to lean heavily on Excel here: let it 
do the work for you, try not to customise too heavily

The Chart Design ribbon is really visual: 
click around and see what you get

To un-table a table, click Convert to Range 
on the Table ribbon…

…but your chart data should be a table if at all possible, 
otherwise your chart might not update with your data

The Quick Layout button is ‘mad’ — Lucy

If you want to get really specific about what’s on your chart, 
use the Add Chart Element button

You can use the same button to remove chart elements

To select specific chart components, use 
the drop-down menu on the Format ribbon

Johnny tends not to click on the chart — 
it’s a bit fussy and easy to get wrong

To format the thing you’ve selected, activate 
the Format Pane from the Format ribbon

Charts (part 2)

You can move a chart to its own sheet using Move Chart

If you do want to update the chart’s data source, 
use Select Data — but be careful, you have to 
know what you’re doing here

We look at how blank cells, or cells with a 
non-numeric value, or cells with the Excel 
error #N/A, are handled

You can choose how the graph displays 
empty cells using the drop-down in Select Data

We make a breakfast pie chart 

🥓🍳☕

Selecting a single data point — vs. a data series — 
is a bit finicky, and can only be done with the mouse

We add a trendline to our weight data

Don’t forget you can just play around with charts: 
if in doubt, undo!

Tables

Tables (part 1)

Lucy shares a revelation 

🦥

To jump to the edges of your data use the 
keyboard shortcut ⌘/ctrl arrow

Holding Shift at the same time selects cells

To ‘start again’ you can copy/paste data but paste 
the values only using Paste Special

We turn our unstructured weight data in 
to a structured Table

Always
Be
Tabling!

Tables (part 2)

You can change the colour of the table and whether it has 
Banded Rows and so on in the Table section of the ribbon

You can turn on a Total Row which can show a 
COUNT, SUM, AVERAGE, and a bunch of other stuff

Your headers always show, even if they’ve scrolled off the 
top of the window – as long as your cursor is in your table

You can Insert Rows in a whole bunch of ways 
and the table will just handle it for you

Tables come with Filters

The Filter is a really nice way of getting a view of all of 
your data; it only shows each value once

You can multi-filter on a bunch of columns

You can Filter anything – the buttons are in the Data ribbon

Tables (part 3)

We use CONCAT to add “kg” to Johnny’s weight

Excel automatically expands the table for us

And a table automatically fills a formula down 
the entire Calculated Column for us

CONCAT does exactly what we ask it to, including 
adding “kg” to a bunch of things that aren’t numbers

So we use ISNUMBER to figure out what’s a number

The Filter is also a really nice way of checking 
that your functions did what you expected

Tables (part 4)

It gets real with our first IF

We use IF to only add “kg” to 
Johnny’s weight if it is a number

We nest a function, using CONCAT as an argument to IF

Then we also bring our ISNUMBER in, nesting it as the 
logical_test of our IF

A common pattern is ‘if some condition, do a thing; 
otherwise just return what was there’

Johnny discovers that the arrows behave differently in the 
Formula Bar than they do when you’re editing directly in a cell

This can help you build your formulas as it’s clearer 
when you have closed all of your brackets

Tables (part 5)

We learn why referencing a whole column, say C:C, 
can lead to problems later

We learn the new cell referencing notation for tables

It’s a lot nicer than C:C because it’s self-descriptive

And you can ‘reach in’ to your data more easily from 
elsewhere in your workbook

Don’t forget to use tab completion to help you select 
what you want – it’s more reliable than typing it yourself

You can – and should always – give your tables 
custom names (vs. ‘Table1’ which you get by default)

Johnny uses the ‘it’s a variable’ convention of giving table 
names lowercase_names_joined_with_underscores

General rule: name your things properly so that you can 
remember what they are! Sounds obvious, but…

Tables (part 6)

If you want to reference this row in a table, use the 
[@[Column name]] syntax

If you’re referencing a table from within the table, 
you don’t need the table name

(And if you type it, Excel will remove it from the formula)

We look at common missing-a-bracket mistakes; 
there’s no real solution, you just need to be careful

We have a quick look at MIN and MAX

And round out tables by showing how we solved 
the ‘weird data in column C’ issue...

…and the ‘having to expand your formula when you add a 
new row’ issue, both of which tables just handles for us 

🎈

Borders and 
simple formatting

Borders and simple 
formatting (part 1)

We explore Lucy’s hatred of the “stupid formatting pencil”

The Clear button allows you to Clear All or Clear Formats 

The Format Cells window makes its first appearance; 
we spend a while messing about in the Border tab

Adding new rows to an already-bordered table can 
be a bit of a faff; there isn’t really a nice solution

There’s a helper that appears when we insert 
row, but it doesn’t help in this instance

Be careful when you use the Fill Handle: by default, it fills 
formatting, which often breaks the lower border

Top tip: try to resist doing your formatting until the very end!

Borders and simple 
formatting (part 2)

You can select the entire sheet using the 
select-all triangle at the top left

You can drag column dividers to resize them, but if you 
want an exact width it’s much easier to use Column Width 
by right-clicking on the column header

(And all of this applies exactly the same to rows)

If you want a ‘quick ’n dirty’ view of what will fit on a page 
when you print, launching Print Preview will put dotted 
lines on your sheet

You can copy/paste entire columns, which 
includes the column widths and all cell formatting

You can Repeat an action just like you can Undo 
an action – ⌘/ctrl Y is the shortcut

(This is really handy for things like inserting a row. 
Insert one row then hit ⌘ Y to do a few more.)

((Although if you select 4 rows first, then right-click 
and Insert, you’ll get 4 more rows…))

The Format Painter is copy/paste for formatting

Double-clicking the Format Painter makes it ‘stick’

We meet the marching ants that appear when 
you’re in Excel’s special ‘copy mode’

Borders and simple 
formatting (part 3)

Row height: selecting multiple rows will show the 
same row height if the rows are the same height; 
otherwise it’ll show you a blank value

⌘ (Mac) or ctrl (Windows) is a near-universal keyboard 
shortcut that will allow you to select a bunch of non-
adjacent stuff

We select two non-adjacent columns and 
make them both the same width

You can vertically align the content in your cells 
using the Alignment tab in Format Cells, or using 
the button on the toolbar

You can also Indent content within a cell

And Wrap Text within a cell

And Merge cells

But watch out, you can get yourself in a pickle if you 
mess about with the grid structure too much

If you need a hard line break within a cell, press 
⌥ return (Mac) or alt return (Windows)

You can align your text in other fancy ways: 
vertically, at a 45° angle, etc.

The fill handle

The fill handle (part 1)

It does numbers!

It does dates!

Don’t forget the little Auto Fill helper button that 
appears: especially useful with things like dates, 
where you can select ‘weekdays’ and so on

You can use it to Copy Cells if that’s what you want

And you can choose to Fill without Formatting, or 
Fill Formatting Only

Double-clicking the fill handle is the quickest way to do 
it, but it needs adjacent data so it knows when to stop

We show the ⌘/ctrl A Select All behaviour, 
and talk about ‘islands’ of data 

🏝

It does formulas!

You can select multiple columns and use the fill handle 
to fill them all at the same time

Don’t forget that the handle works in every direction, 
you don’t have to go down

The fill handle (part 2)

We show the Flash-fill feature (which Johnny 
never remembers to use)

⚠

 Don’t forget that flash-filled data is hard-coded: it 
doesn’t update when the original data updates! 

⚠

You can define your own Custom Lists: so we define 
the names of our chickens

You can import your own Custom Lists from existing Excel cells

Or you can just copy/paste in to the custom list window 
which is simpler and less error-prone

Layout and printing

Layout and printing (part 1)

We look at the three mystery layout buttons 
at the bottom right

Page Layout view shows you a view that looks 
like pieces of paper

Johnny warns us that Excel is not MS Publisher! 
Don’t create your Christmas family newsletter with it

We look at the Page Layout 
section of the ribbon

Page margins

Page orientation:
portrait vs. landscape

Paper size

Set Print Area

Page Break Preview layout looks like a normal Excel 
sheet, but it only shows you what will print, and shows 
you the page breaks with dotted blue lines

We talk about the common problem where people 
press Print and end up with 4 sheets of paper with 
almost nothing on them

Layout and printing (part 2)

Set Print Area tells Excel to only print the specific part 
of the sheet that you select

We quickly look at some other buttons that 
Johnny scoffs at and tells you not to use

Print > Gridlines turns on the gridlines when 
you print a sheet (which is off by default)

Print > Selection is a quick way to just print a selection 
of your sheet; it’s like Set Print Area, but different

Print > Scale to fit lets you jam a bit more on to a 
sheet of paper than would normally fit

Cell referencing

Cell referencing (part 1)

How we get values from somewhere else in our sheet

Why we don’t ‘hard code’ values

The simplest cell reference: B2, C2

Duplicating your formula by copy-pasting; 
by default, copy-paste pastes the formula

…but it changes it so that your cell references 
change if you’ve gone down a row

Using a range: D2:D5

Using two ranges as arguments: SUM(A1:B2, D7:E8)

Cell referencing (part 2)

Referencing a cell in another sheet

sheetname!A1

'sheet name'!A1

Works just fine with a range: 'other sheet'!B2:E4

If you insert or move things, Excel usually just 
takes care of updating cell references

We take a brief look at TODAY

When you change a value, anywhere else that 
references it updates immediately

Clarifying the difference between 
a function and a formula

Each cell has one formula

That formula starts with an =

A formula can be made up of functions 
(but it can also just be a cell reference)

Excel has 471 functions

SUM and TEXTJOIN are functions

Functions & formulas

Functions & formulas (part 1)

From the beginning: what is a function, 
what is its structure

We build the SUM function from 
scratch, using the ‘+’ operator to start

Function arguments (or parameters) are a particular 
type; the return values are also a type

Functions & formulas (part 2)

We build our own function: MAKEANICECUPOFTEA

How Excel shows the function definition, tells you 
what arguments are required, and shows you which 
argument you’re ‘in’ as you type the function

We build a basic ‘address label printer’ using TEXTJOIN

Types

Types (part 1)

What is a type and why do you care?

1+2=3 but one+two doesn’t =three (if you’re a computer)

A string is just some text

A number is … a number! You can do maths on numbers

Fractions, percentages, and currency are all just numbers

Time and date are kinda numbers

Booleans are TRUE/FALSE values

Types (part 2)

We look at dates and show that Excel stores them as a number

The start of ‘Excel time’ is 01/01/1900, which is the number 1

14/12/2021 is the 44,544th day since then

Autosum doesn’t want to work on dates, because they’re the 
wrong type: SUM wants numbers as arguments, not dates

Each cell has one type: you can’t mix types in a cell

Types (bonus)

We talk about a real-world problem with types: the gene 
called ‘MARCH1’ that Excel turned in to a number!
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